Uppgradera bef installation php5 till php7

Webshop Forum Thermiq webinterface Uppgradera bef installation php5 till php7

Detta ämne innehåller 1 svar, har 2 deltagare, och uppdaterades senast av  Anders a 2 månader, 2 veckor sedan.

Visar 2 inlägg - 1 till 2 (av 2 totalt)
  • Författare
    Inlägg
  • #7069

    Mischel
    Deltagare

    Har en fungerande installation av ThermIQ USB som körs på RaspPi (Jessie) och lagrar data på dator med Win 10 och MySQL (Xampp). Har inte vågat uppdatera annat än själva ThermIQ Web så de flesta övriga delarna är från ca 2015. Har nu Apache v2.4.17, Php v5.6.14 och databasen MariaDB v10.1.8.

    Om jag tittar i installationsskriptet för RaspPi är Stretch Lite krav för nya installationer och då installeras även bla php 7.2. Om Jessie identifieras användas istället php 5.

    Innebär det att för att uppdatera till php 7.x måste man först göra en ren nyinstallation till Raspbian Stretch?

    Kommer ThermIQ Web kräva php 7.2 eller högre för att supporta nya funktioner framöver?

    #7070

    Anders a
    Forumledare

    Du kan uppgradera php oberoende av allt annat. För tillfället är Thermiq oberoende av php5 eller 7 men jag testarbara på 7 så på sikt är det nog bra att uppdatera.

    För Normalinstallationen med sqlite så räcker det att backuppa de två databasfilerna och sedan göra en ren installation och flytta tillbaka databasfilerna.

Visar 2 inlägg - 1 till 2 (av 2 totalt)

Du måste vara inloggad för att svara på detta ämne.