Re: Testpiloter till DLINK DNS-323 sökes / Testers needed for DLINK Dns-323

Shop Forum ThermIQ och Linux Testpiloter till DLINK DNS-323 sökes / Testers needed for DLINK Dns-323 Re: Testpiloter till DLINK DNS-323 sökes / Testers needed for DLINK Dns-323

#5697
niclas
Deltagare

OK, här är en sammanfattning av hur jag tror att det gick till:

Här dom förändringar jag gjort i install.txt:

1) install.txt refererar till wiki.dns323.info. Den domänen verkar ha snotts av nån annan, men dns323.kood.org fungerade för mig i stället.

2) Diskarna i DNS-320 mountas på /mnt/HD/HD_a2 i stället för /mnt/HD_a2. Enklast att hämta en patchad funplug med: wget http://wolf-u.li/u/171/ -O /ffp/sbin/fun_plug

3) Det kan hända att man måste slå på och av ftp-servern några gånger för att få kontakt. Jag körde med UTF-8.

4) DNS-323 behöver en annan store-passwd.sh. Hämtas med wget http://wolf-u.li/u/172/ -O /ffp/sbin/store-passwd.sh efter att man loggat in med telnet.

5) Ändra cd /mnt/HD_a2 till cd /mnt/HD/HD_a2 innan wget av setup_script.

6) Efter ./setup_script => reboot. (Krävs för att new_db_sqlite ska hamna i /usr/sbin (?))

7) Jag behövde också skriva http://your-static-ip-addres:8080/check_install.php (dvs MED .php), men här är jag osäker…

Mina förändringar i setups_script:

i) En massa /mnt/HD_a2 => /mnt/HD/HD_a2.

ii) I steg 8 ‘Setup lighttpd web-server’, patcha /ffp/etc/lighttpd.conf med sed -i s:/mnt/HD_a2:/mnt/HD/HD_a2: /ffp/etc/lighttpd.conf

iii) I steg 9 ‘Setup php’. curl levereras numera under net-libs, inte net-misc.

iv) I steg 9, samma som punkt ii) ovan.

v) I steg 9, patcha /ffp/etc/php.ini som punkt ii) ovan.

vi) I steg 11, patcha /ffp/etc/php.ini som punkt ii) ovan.

vii) Steg 12. usb-storage.ko behövs inte och usbserial behövde v2.6.22.18-arm1. Hämtas med wget -T 900 -t 30 http://wolf-u.li/u/284 -O /mnt/HD/HD_a2/ffp/lib/modules/2.6.22.18-arm1/usbserial.ko

viii) /etc/hotplug/usb.agent ger felmeddelande men det verkar ofarligt.(?)

DNS-320 använder också lighttpd som lyssnar på port 80. Efter ombootning verkar bara en web-server startas, oklart vilken och varför. Senast när thermiqs startats så protesterade /ffp/start/lighttpd.sh med WARNING: lighttpd: Already running i ffp.log. Däremot fungerade det att manuellt starta original-lighttpd med /ffp/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf resp. thermiqs: med /ffp/sbin/lighttpd -f /ffp/etc/lighttpd.conf.

lsof -i:80 resp. lsof -i:8080 går att använda för att se vilken web-server som startats.

Hoppas att detta var tillräckligt med info. Jag mailar en modifierad install.txt samt setup_script så du får se ändringarna själv.

Mvh,

niclas.borlin@cs.umu.se, DNS-320, 2TB RAID1, Thermia Diplomat Optimum G2 8

PS. Jag är jättenöjd med thermiq och har fått en massa positiv feedback när jag visat upp resultatet på jobbet och facebook! :)