Testpiloter till DLINK DNS-323 sökes / Testers needed for DLINK Dns-323

Shop Forum ThermIQ och Linux Testpiloter till DLINK DNS-323 sökes / Testers needed for DLINK Dns-323

Etiketter: , , ,

Visar 15 inlägg - 16 till 30 (av 31 totalt)
  • Författare
    Inlägg
  • #5689
    admin
    Deltagare

    En snabb googling tyder på att den har allt för att få det att fungera men jag har inte provat själv så det finns inget ThermIQ-installationsstöd för den.

    B3 verkar ha funnits ute sedan slutet 2010 och verkar rätt kapabel men man kan misstänka att en B4 borde dyka upp snart

    #5690
    ehsqvis
    Deltagare

    Finns ett bra och aktivt forum

    http://forum.excito.net

    Excito använder öppen källkod

    http://www.excito.com/sv/content/oppen-kallkod

    #5691
    niclas
    Deltagare

    Hej!

    Jag håller på att försöka sätta upp en DNS-320 med Thermiq och en Diplomat Optimum G2. Nån som försökt sig på detta än?

    Jag har i vilket fall stegat mig igenom installations-scripten för DNS-323 och försökt gissa mig till varför saker går fel. Än så länge har jag hittat följande:

    1) wiki.dns323.info är nere men dns323.kood.org fungerar till vidare.

    fun_plug:

    2) Alla instanser av /mnt/HD_a2 behöver bytas ut mot /mnt/HD/HD_a2

    3) En ny version av store-passwd.sh behövs

    Se också http://nas-tweaks.net/118/updated-tutorials-for-the-installation-of-fun_plug-0-5-on-the-d-link-dns-320-sharecenter-pulse/

    Jag håller nu på att strula med thermiq-installationsscriptet. Har f.n. fastnat på

    a) i slutet av installationsscriptet skriver den ut

    removing ThermIQ cron job

    stty: can’t open ‘/dev/ttyUSB0’: No such file or directory

    Adding ThermIQ to cron jobs

    Done

    Om jag bootar om DNS:en så klagar den på (i ffp.log):

    **** fun_plug script for DNS-320 ****

    **** (modified from fun_plug script for DNS-323 (2008-08-11 tp@fonz.de)) ****

    Mon Jan 23 14:52:59 CET 2012

    ln -snf /mnt/HD/HD_a2/ffp /ffp

    * Running /ffp/etc/fun_plug.init …

    * Running /ffp/etc/fun_plug.local …

    cp: cannot stat ‘/ffp/thermiq/pkg_dns323/usb.agent’: No such file or directory

    chown: /etc/hotplug/usb.agent: No such file or directory

    chmod: /etc/hotplug/usb.agent: No such file or directory

    insmod: cannot insert ‘/lib/modules/2.6.12.6-arm1/usb-storage.ko’: invalid modul

    e format

    insmod: cannot insert ‘/lib/modules/2.6.12.6-arm1/usbserial.ko’: invalid module

    format

    stty: can’t open ‘/dev/ttyUSB0’: No such device or address

    * Running /ffp/etc/rc …

    * /ffp/start/syslogd.sh inactive

    * /ffp/start/SERVERS.sh inactive

    * /ffp/start/portmap.sh inactive

    * /ffp/start/unfsd.sh inactive

    * /ffp/start/nfsd.sh inactive

    * /ffp/start/ntpd.sh …

    Starting /ffp/bin/ntpd -g -f /tmp/ntp.drift

    * /ffp/start/LOGIN.sh inactive

    * /ffp/start/thermiq.sh …

    stty: can’t open ‘/dev/ttyUSB0’: No such device or address

    Adding ThermIQ to cron jobs

    * /ffp/start/telnetd.sh inactive

    * /ffp/start/sshd.sh …

    Starting /ffp/sbin/sshd

    * /ffp/start/rsyncd.sh inactive

    * /ffp/start/mediatomb.sh inactive

    * /ffp/start/kickwebs.sh inactive

    * /ffp/start/lighttpd.sh …

    WARNING: lighttpd: Already running

    * /ffp/start/inetd.sh inactive

    * OK

    % uname -a

    Linux eddie 2.6.22.18 #23 Wed May 25 15:48:30 CST 2011 armv5tejl unknown

    % dmesg

    Linux version 2.6.22.18 (jack@swtest4) (gcc version 4.2.1) #23 Wed May 25 15:48:30 CST 2011

    CPU: ARM926EJ-S [56251311] revision 1 (ARMv5TE), cr=00053977

    Machine: Feroceon-KW

    Using UBoot passing parameters structure

    Memory policy: ECC disabled, Data cache writeback

    On node 0 totalpages: 32768

    DMA zone: 256 pages used for memmap

    DMA zone: 0 pages reserved

    DMA zone: 32512 pages, LIFO batch:7

    Normal zone: 0 pages used for memmap

    CPU0: D VIVT write-back cache

    CPU0: I cache: 16384 bytes, associativity 4, 32 byte lines, 128 sets

    CPU0: D cache: 16384 bytes, associativity 4, 32 byte lines, 128 sets

    Built 1 zonelists. Total pages: 32512

    Kernel command line: root=/dev/ram console=ttyS0,115200 :::DB88FXX81:egiga0:none

    PID hash table entries: 512 (order: 9, 2048 bytes)

    Console: colour dummy device 80×30

    Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)

    Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)

    Memory: 128MB 0MB 0MB 0MB = 128MB total

    Memory: 123776KB available (4148K code, 252K data, 124K init)

    Calibrating delay loop… 791.34 BogoMIPS (lpj=3956736)

    Mount-cache hash table entries: 512

    CPU: Testing write buffer coherency: ok

    NET: Registered protocol family 16

    CPU Interface


    SDRAM_CS0 ….base 00000000, size 128MB

    SDRAM_CS1 ….disable

    SDRAM_CS2 ….disable

    SDRAM_CS3 ….disable

    PEX0_MEM ….base e8000000, size 128MB

    PEX0_IO ….base f2000000, size 1MB

    INTER_REGS ….base f1000000, size 1MB

    NFLASH_CS ….base fa000000, size 2MB

    SPI_CS ….base f4000000, size 16MB

    BOOT_ROM_CS ….no such

    DEV_BOOTCS ….no such

    CRYPT_ENG ….base f0000000, size 2MB

    Marvell Development Board (LSP Version KW_LSP_4.3.4_patch30)– DB-88F6281A-BP Soc: 88F6281 A1 LE

    Detected Tclk 166666667 and SysClk 200000000

    MV Buttons Device Load

    Marvell USB EHCI Host controller #0: c05c3600

    PEX0 interface detected no Link.

    PCI: bus0: Fast back to back transfers enabled

    SCSI subsystem initialized

    usbcore: registered new interface driver usbfs

    usbcore: registered new interface driver hub

    usbcore: registered new device driver usb

    Time: kw_clocksource clocksource has been installed.

    NET: Registered protocol family 2

    IP route cache hash table entries: 1024 (order: 0, 4096 bytes)

    TCP established hash table entries: 4096 (order: 3, 32768 bytes)

    TCP bind hash table entries: 4096 (order: 2, 16384 bytes)

    TCP: Hash tables configured (established 4096 bind 4096)

    TCP reno registered

    checking if image is initramfs…it isn’t (no cpio magic); looks like an initrd

    Freeing initrd memory: 1529K

    cpufreq: Init kirkwood cpufreq driver

    cpufreq: High frequency: 800000KHz – Low frequency: 200000KHz

    cpufreq: Setting CPU Frequency to 800000 KHz

    cpufreq: Setting PowerSaveState to off

    XOR registered 1 NET_DMA over 4 channels

    XOR 2nd invalidate WA enabled

    cesadev_init(c00119d8)

    mvCesaInit: sessions=640, queue=64, pSram=f0000000

    Warning: TS unit is powered off.

    MV Buttons Driver Load

    VFS: Disk quotas dquot_6.5.1

    Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)

    squashfs: version 3.3 (2007/10/31) Phillip Lougher

    squashfs: LZMA suppport for slax.org by jro

    Installing knfsd (copyright (C) 1996 okir@monad.swb.de).

    JFFS2 version 2.2. (NAND) © 2001-2006 Red Hat, Inc.

    fuse init (API version 7.8)

    SGI XFS with large block numbers, no debug enabled

    io scheduler noop registered

    io scheduler anticipatory registered (default)

    Serial: 8250/16550 driver $Revision: 1.7 $ 4 ports, IRQ sharing disabled

    serial8250.0: ttyS0 at MMIO 0xf1012000 (irq = 33) is a 16550A

    serial8250.0: ttyS1 at MMIO 0xf1012100 (irq = 34) is a 16550A

    RAMDISK driver initialized: 16 RAM disks of 10240K size 1024 blocksize

    loop: module loaded

    Loading Marvell Ethernet Driver:

    o Cached descriptors in DRAM

    o DRAM SW cache-coherency

    o Single RX Queue support – ETH_DEF_RXQ=0

    o Single TX Queue support – ETH_DEF_TXQ=0

    o TCP segmentation offload enabled

    o LRO support supported

    o Receive checksum offload enabled

    o Transmit checksum offload enabled

    o Network Fast Processing (Routing) supported

    o Driver ERROR statistics enabled

    o Driver INFO statistics enabled

    o Proc tool API enabled

    o SKB Reuse supported

    o SKB Recycle supported

    o Rx descripors: q0=128

    o Tx descripors: q0=532

    o Loading network interface(s):

    o register under egiga0 platform

    o egiga0, ifindex = 1, GbE port = 0

    Warning: Giga 1 is Powered Off

    mvFpRuleDb (c07a9000): 1024 entries, 4096 bytes

    Integrated Sata device found

    scsi0 : Marvell SCSI to SATA adapter

    scsi1 : Marvell SCSI to SATA adapter

    scsi 0:0:0:0: Direct-Access Seagate ST2000DL003-9VT1 CC32 PQ: 0 ANSI: 5

    scsi 1:0:0:0: Direct-Access Seagate ST2000DL003-9VT1 CC32 PQ: 0 ANSI: 5

    scsi 0:0:0:0: Attached scsi generic sg0 type 0

    scsi 1:0:0:0: Attached scsi generic sg1 type 0

    NFTL driver: nftlcore.c $Revision: 1.1.1.1 $, nftlmount.c $Revision: 1.1.1.1 $

    NAND device: Manufacturer ID: 0xec, Chip ID: 0xf1 (Samsung NAND 128MiB 3,3V 8-bit)

    Scanning device for bad blocks

    Bad eraseblock 68 at 0x00880000

    Bad eraseblock 795 at 0x06360000

    Using static partition definition

    Creating 6 MTD partitions on “nand_mtd”:

    0x00000000-0x00100000 : “u-boot”

    0x00100000-0x00600000 : “uImage”

    0x00600000-0x00b00000 : “ramdisk”

    0x00b00000-0x07100000 : “image”

    0x07100000-0x07b00000 : “mini firmware”

    0x07b00000-0x08000000 : “config”

    ehci_marvell ehci_marvell.70059: Marvell Orion EHCI

    ehci_marvell ehci_marvell.70059: new USB bus registered, assigned bus number 1

    ehci_marvell ehci_marvell.70059: irq 19, io base 0xf1050100

    ehci_marvell ehci_marvell.70059: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004

    usb usb1: configuration #1 chosen from 1 choice

    hub 1-0:1.0: USB hub found

    hub 1-0:1.0: 1 port detected

    ohci_hcd: 2006 August 04 USB 1.1 ‘Open’ Host Controller (OHCI) Driver

    USB Universal Host Controller Interface driver v3.0

    mice: PS/2 mouse device common for all mice

    i2c /dev entries driver

    md: linear personality registered for level -1

    md: raid0 personality registered for level 0

    md: raid1 personality registered for level 1

    device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised: dm-devel@redhat.com

    dm_crypt using the OCF package.

    cpufreq: Setting CPU Frequency to 800000 KHz

    cpufreq: Setting PowerSaveState to off

    usb 1-1: new full speed USB device using ehci_marvell and address 2

    usb 1-1: configuration #1 chosen from 1 choice

    usbcore: registered new interface driver usbhid

    drivers/hid/usbhid/hid-core.c: v2.6:USB HID core driver

    TCP cubic registered

    NET: Registered protocol family 1

    NET: Registered protocol family 17

    md: Autodetecting RAID arrays.

    md: autorun …

    md: … autorun DONE.

    RAMDISK: Compressed image found at block 0

    EXT2-fs warning: maximal mount count reached, running e2fsck is recommended

    VFS: Mounted root (ext2 filesystem).

    Freeing init memory: 124K

    sd 0:0:0:0: [sda] 3907029168 512-byte hardware sectors (2000399 MB)

    sd 0:0:0:0: [sda] Write Protect is off

    sd 0:0:0:0: [sda] Mode Sense: 23 00 10 00

    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, supports DPO and FUA

    sd 0:0:0:0: [sda] 3907029168 512-byte hardware sectors (2000399 MB)

    sd 0:0:0:0: [sda] Write Protect is off

    sd 0:0:0:0: [sda] Mode Sense: 23 00 10 00

    sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, supports DPO and FUA

    sda: sda1 sda2 sda4

    sd 0:0:0:0: [sda] Attached SCSI disk

    sd 1:0:0:0: [sdb] 3907029168 512-byte hardware sectors (2000399 MB)

    sd 1:0:0:0: [sdb] Write Protect is off

    sd 1:0:0:0: [sdb] Mode Sense: 23 00 10 00

    sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, supports DPO and FUA

    sd 1:0:0:0: [sdb] 3907029168 512-byte hardware sectors (2000399 MB)

    sd 1:0:0:0: [sdb] Write Protect is off

    sd 1:0:0:0: [sdb] Mode Sense: 23 00 10 00

    sd 1:0:0:0: [sdb] Write cache: enabled, read cache: enabled, supports DPO and FUA

    sdb: sdb1 sdb2 sdb4

    sd 1:0:0:0: [sdb] Attached SCSI disk

    usbcore: registered new interface driver usblp

    drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver

    egiga0: mac address changed

    egiga0: link up, full duplex, speed 100 Mbps

    egiga0: started

    kjournald starting. Commit interval 5 seconds

    EXT3 FS on sda4, internal journal

    EXT3-fs: recovery complete.

    EXT3-fs: mounted filesystem with ordered data mode.

    kjournald starting. Commit interval 5 seconds

    EXT3 FS on sdb4, internal journal

    EXT3-fs: recovery complete.

    EXT3-fs: mounted filesystem with ordered data mode.

    Initializing USB Mass Storage driver…

    scsi2 : SCSI emulation for USB Mass Storage devices

    usbcore: registered new interface driver usb-storage

    USB Mass Storage support registered.

    usb-storage: device found at 2

    usb-storage: waiting for device to settle before scanning

    md: md0 stopped.

    md: bind<sdb1>

    md: bind<sda1>

    raid1: raid set md0 active with 2 out of 2 mirrors

    md: md1 stopped.

    md: bind<sdb2>

    md: bind<sda2>

    raid1: raid set md1 active with 2 out of 2 mirrors

    EXT3 (no)user_xattr options not supported

    kjournald starting. Commit interval 5 seconds

    EXT3 FS on md1, internal journal

    EXT3-fs: recovery complete.

    EXT3-fs: mounted filesystem with ordered data mode.

    Adding 530040k swap on /dev/md0. Priority:-1 extents:1 across:530040k

    scsi 2:0:0:0: Direct-Access ThermIQ Mass Storage 0001 PQ: 0 ANSI: 4

    usb-storage: device scan complete

    NTFS driver 2.1.28 [Flags: R/O MODULE].

    usb_storage: version magic ‘2.6.12.6-arm1 ARMv5 gcc-3.3’ should be ‘2.6.22.18 mod_unload ARMv5 ‘

    usbserial: version magic ‘2.6.12.6-arm1 ARMv5 gcc-3.3’ should be ‘2.6.22.18 mod_unload ARMv5 ‘

    Nån som har nån ledtråd på hur jag ska gå vidare? dmesg föreslår att jag ska leta en usb_storage.ko och usbserial.ko som är kompatible med min kernel. Var? Nånting annat?

    Jag lovar att posta en fullständig uppdatering när jag får min DNS-320 att fungera.

    Mvh,

    /Niclas

    #5692
    niclas
    Deltagare

    Oh, yes:

    # lsusb

    Bus 001 Device 002: ID 04d8:fdeb Microchip Technology, Inc.

    Bus 001 Device 001: ID 0000:0000

    #5693
    niclas
    Deltagare

    Eureka! Kan meddela att jag nu fått min DNS-320 att samarbeta med Thermiq. :)

    #5694
    admin
    Deltagare

    Berätta gärna vad du gjorde för att få till det….

    #5695
    niclas
    Deltagare

    Eureka! Kan meddela att jag nu fått min DNS-320 att samarbeta med Thermiq. :)

    #5696
    niclas
    Deltagare

    Sorry, mail kommer…

    #5697
    niclas
    Deltagare

    OK, här är en sammanfattning av hur jag tror att det gick till:

    Här dom förändringar jag gjort i install.txt:

    1) install.txt refererar till wiki.dns323.info. Den domänen verkar ha snotts av nån annan, men dns323.kood.org fungerade för mig i stället.

    2) Diskarna i DNS-320 mountas på /mnt/HD/HD_a2 i stället för /mnt/HD_a2. Enklast att hämta en patchad funplug med: wget http://wolf-u.li/u/171/ -O /ffp/sbin/fun_plug

    3) Det kan hända att man måste slå på och av ftp-servern några gånger för att få kontakt. Jag körde med UTF-8.

    4) DNS-323 behöver en annan store-passwd.sh. Hämtas med wget http://wolf-u.li/u/172/ -O /ffp/sbin/store-passwd.sh efter att man loggat in med telnet.

    5) Ändra cd /mnt/HD_a2 till cd /mnt/HD/HD_a2 innan wget av setup_script.

    6) Efter ./setup_script => reboot. (Krävs för att new_db_sqlite ska hamna i /usr/sbin (?))

    7) Jag behövde också skriva http://your-static-ip-addres:8080/check_install.php (dvs MED .php), men här är jag osäker…

    Mina förändringar i setups_script:

    i) En massa /mnt/HD_a2 => /mnt/HD/HD_a2.

    ii) I steg 8 ‘Setup lighttpd web-server’, patcha /ffp/etc/lighttpd.conf med sed -i s:/mnt/HD_a2:/mnt/HD/HD_a2: /ffp/etc/lighttpd.conf

    iii) I steg 9 ‘Setup php’. curl levereras numera under net-libs, inte net-misc.

    iv) I steg 9, samma som punkt ii) ovan.

    v) I steg 9, patcha /ffp/etc/php.ini som punkt ii) ovan.

    vi) I steg 11, patcha /ffp/etc/php.ini som punkt ii) ovan.

    vii) Steg 12. usb-storage.ko behövs inte och usbserial behövde v2.6.22.18-arm1. Hämtas med wget -T 900 -t 30 http://wolf-u.li/u/284 -O /mnt/HD/HD_a2/ffp/lib/modules/2.6.22.18-arm1/usbserial.ko

    viii) /etc/hotplug/usb.agent ger felmeddelande men det verkar ofarligt.(?)

    DNS-320 använder också lighttpd som lyssnar på port 80. Efter ombootning verkar bara en web-server startas, oklart vilken och varför. Senast när thermiqs startats så protesterade /ffp/start/lighttpd.sh med WARNING: lighttpd: Already running i ffp.log. Däremot fungerade det att manuellt starta original-lighttpd med /ffp/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf resp. thermiqs: med /ffp/sbin/lighttpd -f /ffp/etc/lighttpd.conf.

    lsof -i:80 resp. lsof -i:8080 går att använda för att se vilken web-server som startats.

    Hoppas att detta var tillräckligt med info. Jag mailar en modifierad install.txt samt setup_script så du får se ändringarna själv.

    Mvh,

    niclas.borlin@cs.umu.se, DNS-320, 2TB RAID1, Thermia Diplomat Optimum G2 8

    PS. Jag är jättenöjd med thermiq och har fått en massa positiv feedback när jag visat upp resultatet på jobbet och facebook! :)

    #5698
    admin
    Deltagare

    Nu finns en uppdaterad installationsbeskrivning för DNS320, DNS323 och DNS325 på

    https://www.thermiq.net/ThermIQ_Client/pkg_dns32x/ThermIQ_installation_for_DNS-32x.pdf

    #5699
    sveinmer
    Deltagare

    Hei Niclas,

    Fungerer e-mail vid larm som det skal også?

    Mvh,

    Svein Erlandsen

    #5700
    sveinmer
    Deltagare

    Hej,

    Kommer det att utvecklas en script for fonz fun plug 0.7 också?

    Mvh,

    Svein

    #5701
    admin
    Deltagare

    inte just nu iallafall. ThermIQ rullar bra på funz plug 0.5.

    Är det någon speciell feature du saknar från 0.7

    #5702
    sveinmer
    Deltagare

    Nej, inget speciellt, endast att jag inte fick det at fungere med 0.7

    jag klarar generellt inte at se någon ny version utan att prova…

    Mvh,

    Svein Erlandsen

    #5703
    niclas
    Deltagare

    Hej! Har nu testat på min DNS-320 och fått det mesta att fungera. Men i steg 7a måste man byta ut alla referenser till /mnt/HD_a2 (som fungerar för DNS-323) i fun_plug till /mnt/HD/HD_a2. Vet inte vad som gäller för en DNS-325, nån kanske kan prova bägge och meddela?

    Dessutom var jag i steg 14 tvungen att skriva http://ip-address:8080/check_install.php (MED .php). Kanske självklart för andra men inte för mig.

    Loggning fungerar nu stabilt och Thermiq:s web-server samsas fint med DNS:ens egen. Däremot verkar widget-sidan (Administration/Widgets) vara trasig. Jag har tappat huset och gårdagens sammanfattning och kan inte återställa. Har meddelat Anders om problemen.

    Svein, nej jag får inte email-larm att fungera såvitt jag kan se. Larmtest-knappen ger mig ingen feedback alls och heller inget mail. Vad bör man få för feedback där? Dialog med ‘Mail skickat’ eller bara ett email som förhoppningsvis kommer fram nånstans?

    Mvh,

    /Niclas

Visar 15 inlägg - 16 till 30 (av 31 totalt)
  • Du måste vara inloggad för att svara på detta ämne.