MQTT Firmware 2.22 – Register-Names with “d” instead of “r”

Shop Forums ThermIQ in english General MQTT Firmware 2.22 – Register-Names with “d” instead of “r”

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #7633
    pbm
    Participant

    Hi Anders,

    i pushed the Update-Button an the ThermIQ installed version 2.22

    Now the registernames are with “d” instead of “r”.

    Was this intentional?

    It’s usually not that nice to change the registernames…

    Is there a function to change that back to “r”?

    Or is it planned to correct that with the next firmware update?

    Example:

    {
    “Client_Name”: “ThermIQ_xxxxxxxxxxxx”,
    “app_info”: “ThermIQ-mqtt 2.22”,
    “reason”: “T”,
    “rssi”: -61,
    “d0”: 7,
    “d1”: 20,
    “d2”: 0,
    “d3”: 23,
    “d4”: 0,
    “d5”: 60,
    “d6”: 58,
    “d7”: 58,

    #7636
    Anders a
    Keymaster

    Hi PBM, I’m sorry that this cought you unaware.

    Yes this is an intentional change to make it easier for us humans to read and has been syncronized with support in the ThermIQ-web poller and HomeAssistant integration as well as the documentation. The old notation is still allowed when sending writes.

    It’s possible to revert back to old, hex-format, rXX by:
    ThermIQ/ThermIQ-mqtt/set {”REGFMT”:0}

    See also the documentation at:
    http://thermiq.net/ThermIQ_MQTT_Installation.pdf

    #7637
    pbm
    Participant

    Hi Anders,

    thanks for the information.

    With the new documentation, i changed my settings to decimal.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.