ThermIQ-MQTT not writing to ThermIQ-Web

Shop Forums ThermIQ in english ThermIQ-MQTT not writing to ThermIQ-Web


Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #7822
    Petri Ketola

    Got the ThermIQ-MQTT working and that is now attached to the pump. MQTT Explorer is able to connect to the client and the values on the MQTT Explorer are being updated every 30 seconds. They match with the numbers on the pump’s UI.

    I still have problems with the ThermIQ-Web. The numbers do not flow that way from the client. There seems to be some kind of issue with connection to the mosquitto MQTT server? Here’s the log from the shell:


    MQTT Client_Name[ThermIQ_EC62609BCB5C]
    MQTT Subscribe to[ThermIQ/ThermIQ-mqtt/data]
    Error: ThermIQ_MQTT_listener. An exception occurred. PhpMqtt\Client\Exceptions\DataTransferException: [65] Transferring data over socket failed: Sending data over the socket failed. Has it been closed? in /var/www/vendor/php-mqtt/client/src/MqttClient.php:1041
    Stack trace:
    #0 /var/www/vendor/php-mqtt/client/src/MqttClient.php(1005): PhpMqtt\Client\MqttClient->writeToSocket()
    #1 /var/www/vendor/php-mqtt/client/src/MqttClient.php(614): PhpMqtt\Client\MqttClient->ping()
    #2 /usr/sbin/ThermIQ_MQTT_listener(307): PhpMqtt\Client\MqttClient->loop()
    #3 {main}


    Again any guidance where to start resolution?

    Thanks, Petri

    Petri Ketola

    And found the solution – had not updated listener’s subscription node name to match the one coming out from the client.

    Hope this helps

    Anders a

    Please check your poller settings (Settings->Poller settings) or the file /opt/etc/Thermiq_linux.ini and make sure it looks similar to:

    enabled = 1
    MQTTServer_IP = ‘’
    MQTTServer_Port = 1883
    MQTTServer_User = ‘thermiq’
    MQTTServer_PW = ‘xxxxxxx’
    MQTTServer_Cafile = ”
    MQTTClient_Name = ‘ThermIQ_30AAAAAAAA’
    MQTTNode = ‘ThermIQ/ThermIQ-room2’

    Please note that you have to restart the PI (or the poller service…) before changes come inte effect.

    One way to test out settings without restarting is to type the following into a ssh connection:

    ThermIQ-MQTT_listener -v

    and observe the output

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.