Klockan går fel.

Shop Forum ThermIQ och Linux Klockan går fel.

Visar 15 inlägg - 1 till 15 (av 17 totalt)
  • Författare
    Inlägg
  • #6761
    Paxman
    Medlem

    Hej,

    Detta kanske är en korkad fråga…men hur ställer jag klockan i ThermIQ? Eller snarare är väl frågan var ThermIq får data för tid och datum ifrån?

    Jag bröt strömmen för hela huset idag under ett antal timmar och nu när jag skulle kolla till pumpen via ThermIQ ser jag att klockan går helt fel. Dessutom verkar den ha stannat på 14:56.

    Jag har sökt i alla inställningar utan att hitta något ställe, varken i pumpen eller i ThermIQs inställningar, där jag kan ändra tiden. Kommer tidsdata från Raspberryn tro?

    Mvh
    Fred

    #6768
    Anders a
    Keymaster

    Hej Fred,
    ThermmIQ har ingen egen klocka utan använder raspberryns inbyggda. Den synkar normalt över nätet mot något atomur.

    /&&

    #6779
    Paxman
    Medlem

    Tack för svaret Anders! Då vet jag att det är i Raspberryn jag måste felsöka. Det kan vara så att hallonet inte hade nätverkskabeln ipluggad när jag slog på strömmen igen och att den därför inte lyckats uppdatera mot klockservern. Testar att starta om den nu, med nätverket igång och ipluggat.

    #6780
    Paxman
    Medlem

    Omstart gjorde ingen nytta och nu har jag tillbringat flera timmar med att försöka få klockan i Rasberryn att gå rätt, tyvärr utan att lyckas. På något sätt lyckades jag få till en ändring, men tyvärr klantade jag mig så jag ändrade årtalet till 2017 och nu spelar det ingen roll vad jag gör. Det funkar att ändra datum och tid i hallonet tillfälligt, men så fort jag bootar om är tiden tillbaka till 2017.

    Med tid och datum så fel är min ThermIQ i princip värdelös. 🙁

    #6782
    Paxman
    Medlem

    Idag har felsökningen fortsatt och vad jag kunnat utröna så är det något med NTP-serverkommunikationen som strular i Hallonet. Vad jag förstått använder NTP port 123 för att komma ut på tidsserverna och synka tiden mot dem. Då dessa problem uppstod när jag gick från ADSL till fiber misstänker jag att detta ligger hos min ISP, eller möjligen stadsnätsleverantören.

    Min ISP hävdar att de inte blockerar någonting, men de skulle kolla med stadsnätsoperatören och se ifall de har några begränsningar inlagda.

    #6784
    Paxman
    Medlem

    Nu har jag äntligen fått klockan att gå rätt i Raspberryn! Dock har detta inte rättat till felet i ThermIQ, där ligger fortfarande tiden fel med nästan ett helt år. I skrivande stund visar ThermIQs klocka: 2017-11-24 05:01:00 där Raspberryns visar: Thu Nov 24 23:53:47 CET 2016

    Jag har gjort ThermIQ strömlös och pluggat i den igen, men det hjälpte inte.

    #6785
    Paxman
    Medlem

    Uppdatering:

    När jag kollade runt i ThermIQ såg jag följande:

    Först det jag rapporterat tidigare, ett knappt år fel under hembilden (samt i rådata):

    Sen gick jag in under Thermia översikt och upptäckte detta:

    Så på något sätt får ThermIQ rätt tid…men den sätter inte ut den i hembilden eller i rådata.

    #6788
    Paxman
    Medlem

    ThermIQ har låst sig vid 2017-11-24 05:01:00. Det som första bilden visar ändrar sig inte, och kurvorna uppdateras inte. Tiden i “Thermia översikt” uppdateras dock.

    Anders, jag behöver lite hjälp här…

    #6789
    Paxman
    Medlem

    Har du inget förslag på vad jag kan göra Anders? Min ThermIQ är obrukbar nu.

    #6790
    Mischel
    Deltagare

    Något du kanske kan testa är att ta backup på databasen och skapa en ny. Kan ju hända att den får snurr när det finns data lagrad i den som ligger i framtiden. Om det fungerar då får du nog manuellt gå in i den gamla databasen och rensa bort den datan.

    #6791
    Paxman
    Medlem

    Ja, jag funderar på just det…att ThermIQ inte kan jobba när det finns data från framtiden. Jag har tänkt i just de banorna som du skriver Mischel, backa upp databasen och testa med en ny. Går ThermIQ igång då är det ju troligt att problemet beror på framtidsdatan. I så fall måste jag ta reda på hur jag ändrar i den gamla databasen.

    #6792
    Paxman
    Medlem

    OK, nu har jag klurat ut hur jag kopierar filer från Rasberryn till min Mac via SSH med hjälp av Rubberduck, så nu skulle jag kunna labba lite med att ändra i databasen.

    I kommunikation med Anders tidigare gällande en helt annan sak uppmanades jag att backa upp följande filer:

    /opt/etc/Thermiq_Linux.ini
    /var/sqlite/hpdb
    /var/sqlite/hptempdb

    Och jag gissar att “db” står för databas i de två senare.

    Jag hittar den första: Thermiq_Linux.ini under /opt/etc/, men i /var/sqlite/ ser jag bara:

    thermiq_tom.db
    thermiq_user.db
    thermiq.db

    Är det dessa jag ska ha som backup om jag vill be ThermIQ att skapa en ny databas?

    När jag öppnar filerna i Firefox-tillägget SQLite-hanteraren ser jag data, men inget jag kunde identifiera som datum, som jag skulle kunna ändra om det visar sig att ThermIQ vaknar med en ny databas.

    Någon som har en idé?

    #6793
    Paxman
    Medlem

    Eftersom jag inte får några svar här gav jag upp och gjorde en nyinstallation av ThermIQ trots att jag inte är säker på att alla mina data är uppbackade. Tyvärr gjorde inte en ominstallation av ThermIQ via GUIt någon skillnad, datum och tid är fortfarande fel och systemet är låst. Det konstiga är att trots att jag gjort total ominstallation, inklusive “Create and Init Main database”, så finns de felaktiga rådata fortfarande kvar.

    Verkar som att jag kan slänga ThermIQ nu.

    #6796
    Anders a
    Keymaster

    Sorry för sent svar. Forumet har slutat maila mig när det kommer nya meddelanden så jag har missat denna tråd.

    En fråga, uppdateras rådata graferna med ny data eller är dom oxo frysta?

    Vad gäller backup så kör du “nya” ThermIQ2. Då går du in på installation och väljer backup mod dropbox så sparas dina databaser i molnet.

    /&&

    #6801
    Paxman
    Medlem

    Hej Anders, tack för att du svarade…jag hade helt börjat ge upp hoppet om min ThermIQ.

    Nej, rådata uppdateras inte. Tror inte att data på “framsidan” uppdateras heller, alltså sidan med väderwidgeten och den grafiska bilden av pumpen. Dock snurrar brinepumpen i bilden av pumpen.

    Jag har avslutat min dropbox, så jag kopierade de filer jag skrev i tidigare inlägg via SSH till min MacBook. Sen hittade jag ett program som kunde klona SD-kort, så nu har jag också en image-fil av hela kortet. Detta gjorde jag innan jag testade ominstallationen, som ju inte verkade göra något.

    EDIT:

    Glömde skriva att jag inte heller får mail om svar på forumet, trots att detta är ikryssat.

Visar 15 inlägg - 1 till 15 (av 17 totalt)
  • Du måste vara inloggad för att svara på detta ämne.