problem vid apt-get upgrade

Shop Forum ThermIQ och Linux problem vid apt-get upgrade

Visar 5 inlägg - 1 till 5 (av 5 totalt)
  • Författare
    Inlägg
  • #6563
    qvist
    Medlem

    körde lite uppdateringar av raspbian. fick detta i loggen

    insserv: warning: script ‘ThermIQ_Startup’ missing LSB tags and overrides
    insserv: There is a loop between service zbw_connect and ThermIQ_Startup if stopped
    insserv: loop involving service ThermIQ_Startup at depth 2
    insserv: loop involving service zbw_connect at depth 1
    insserv: Stopping ThermIQ_Startup depends on zbw_connect and therefore on system facility `$all’ which can not be true!
    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: error processing ntp (–configure):
    subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    ntp
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    kollade i loggen och jag fick liknande vid installation.
    antar att det kanske inte behövs så mycket mer info om vad som är fel?

    #6566
    Anders a
    Keymaster

    Nytt för mig. Ska kolla lite i helgen.

    Vilken raspbian release kör du?

    #6567
    qvist
    Medlem

    rasberry pi ver B+

    uname -a
    Linux raspberrypi 3.18.5+ #744 PREEMPT Fri Jan 30 18:19:07 GMT 2015 armv6l GNU/Linux

    cat /etc/debian_version
    7.8

    tog ner image från raspberrypi.org och har uppdaterat den själv (apt-get)

    Om det spelar roll så har jag nyligen köpt och kopplat in thermiq:en. den är inte kopplad mot en vp ännu.

    verkar som jag kör Release:2.7.2 Revision: 512 av thermiq. ej beta.

    har även en z-wave kontroller installerad. (z-wave.me/razberry)

    #6569
    qvist
    Medlem

    kan vara z.wave.me som stökar lite.

    /etc/init.d/zbw_connect börjar så här:

    #!/bin/bash
    ### BEGIN INIT INFO
    # Provides: zbw_connect
    # Required-Start: $all
    # Required-Stop: $all
    # Default-Start: 2 3 4 5
    # Default-Stop: 0 1 6
    # Short-Description: zbw_connect
    # Description: the script to connect to zbw server
    ### END INIT INFO

    kanske kan /etc/init.d/ThermIQ_Startup ändras lite för att få båda att fungera samtidigt?

    #6572
    Anders a
    Keymaster

    verkar som att både thermiq och zbw_connect vill att allt annat startart innan den själv startar. Man kan säkert ändra:
    # Required-Start: $all
    till nått mer specifikt.

Visar 5 inlägg - 1 till 5 (av 5 totalt)
  • Du måste vara inloggad för att svara på detta ämne.