./setup_script: 157: ./setup_script: Syntax error: newline unexpected

Shop Forum Installation ./setup_script: 157: ./setup_script: Syntax error: newline unexpected

Visar 9 inlägg - 1 till 9 (av 9 totalt)
  • Författare
    Inlägg
  • #6696
    angsvagen
    Medlem

    Hej!

    Har nu försökt installera på Raspberry Pi flera ggr från formaterat SD-kort och får samma felmeddelande. De sista raderna i log:en lyder:

    The following NEW packages will be installed:
    picocom
    0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
    Need to get 23.0 kB of archives.
    After this operation, 82.9 kB of additional disk space will be used.
    Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main picocom armhf 1.7-1 [23.0 kB]
    Fetched 23.0 kB in 0s (66.7 kB/s)
    Selecting previously unselected package picocom.
    (Reading database …
    (Reading database … 5%
    (Reading database … 10%
    (Reading database … 15%
    (Reading database … 20%
    (Reading database … 25%
    (Reading database … 30%
    (Reading database … 35%
    (Reading database … 40%
    (Reading database … 45%
    (Reading database … 50%
    (Reading database … 55%
    (Reading database … 60%
    (Reading database … 65%
    (Reading database … 70%
    (Reading database … 75%
    (Reading database … 80%
    (Reading database … 85%
    (Reading database … 90%
    (Reading database … 95%
    (Reading database … 100%
    (Reading database … 82657 files and directories currently installed.)
    Unpacking picocom (from …/picocom_1.7-1_armhf.deb) …
    Processing triggers for man-db …
    Setting up picocom (1.7-1) …
    mkdir: cannot create directory `/var/www’: File exists
    ##### USB Device ###############################################################
    sed: can’t read /etc/modprobe.d/raspi-blacklist.conf: No such file or directory
    sed: can’t read /etc/modprobe.d/raspi-blacklist.conf: No such file or directory
    libkmod: ERROR ../libkmod/libkmod.c:554 kmod_search_moddep: could not open moddep file ‘/lib/modules/3.18.11+/modules.dep.bin’
    ./setup_script: 157: ./setup_script: Syntax error: newline unexpected

    Missar jag någon detalj eller finns det något annat tips?

    #6698
    Anders a
    Keymaster

    Det är nu fixat tillsamman med lite smidigare setup av Tellstick och experimentel support för Rasbian Jessie

    #6699
    Anonym
    Inaktiv

    exakt samma problem här. vad gör man

    #6701
    Anders a
    Keymaster

    Ladda ner scriptet igen och kör.

    #6702
    Anonym
    Inaktiv

    Det jag gör är att köra detta script via Putty ifrån en win7 dator

    cd /tmp
    rm setup_script
    sudo wget https://www.thermiq.net/getThermIQ2.php?setup=raspberry -O setup_script sudo chmod a+x setup_script
    sudo ./setup_script 2>&1 | sudo tee /var/thermiq_install.log

    Prövade 3 gånger igår och det gick inte så bra samma fel alla gånger

    #6703
    Anders a
    Keymaster

    Det kan vara nödvändigt att skriva
    sudo rm /etc/setup_script
    för att ta bort det gamla scriptet innan man laddar ner det nya med sudo wget……

    #6704
    Anonym
    Inaktiv

    jag gör nog nåt annat fel då för jag raderade kortet samtliga gånger så nåt gammalt kan inte vara kvar

    #6705
    Anonym
    Inaktiv

    Bättre tur idag för nu gick det. Men vet inte varför det inte fungerade igår gjorde exakt samma idag

    #6706
    Anders a
    Keymaster

    I’m sorry for creating problems for new installations on Raspberry but it seems I brook the installation script in several places when trying to update it for Raspbian Jessie. I think it is finally under control now from version 455

Visar 9 inlägg - 1 till 9 (av 9 totalt)
  • Du måste vara inloggad för att svara på detta ämne.