How to replace ThermIQ-Link with ThermIQ-MQTT

Shop Forums Installation How to replace ThermIQ-Link with ThermIQ-MQTT

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #7618
    zeppo69
    Participant

    Hi,
    I have been using a happy user of ThermIQ2-WEB running in Raspberry Pi 3 B+ board since 2016.
    The heatpump is Danfoss DHP-H10 with Thermiq-Link installed.

    Because of a silly accident, I managed to break the old Thermiq-Link card in several pieces,
    and noticed I can’t get another new card like that anymore.
    Thus, I ordered this week a new Thermiq-MQTT card which should arrive soon.

    How should I reconfigure the ThermIQ2-WEB to use MQTT as data source:
    If I check the poller settings, there’s these for old ThermIQ-Link:
    – poller_ThermIQ
    — poller_mode: COM
    — com_device: /dev/ttyUSB0
    — ip_addr: IP:192.0.0.2:2000

    Two questions:

    1. How would I continue with minimal changes to get ThermIQ-MQTT configured for polling?
    Or at least I don’t want to lose the old data, while I never configured
    the dropbox connection for backups. I have a backup of the microSD card.

    2. I know the administrator password, and I can also access the Raspberry Pi with ssh.
    If I select Settings->Installation/Backup another login is needed, and I have forgotten this.
    Can this be resetted, or changed with a console connection?

    Best Regards,
    Seppo

    #7620
    Anders a
    Keymaster

    There are two paths, the first is easy and the one I would recommend.

    Alt 1
    Make a backup of the database files:
    /var/sqlite/*.db

    Re-install your raspberry from scratch using Raspbian 11 following the default installation instruction including configuration of ThermIQ_MQTT. When everything works, copy the db-files back and overwrite the new db-files. Then go back to Settings->Installation and do “Update database” to ensure that you have latest db-format.

    Alt 2
    This is an outline of update in place (but not verified to work):
    – Go to Settings->installation/Backup and make sure that ThermIQ MQTT is selected as Enabled Modules
    – Open /opt/etc/Thermiq_Linux.ini and make sure that poller_ThermIQ is disabled and poller_ThermIQ_MQTT is enabled

    [poller_ThermIQ]
    enabled = 0

    [poller_ThermIQ_MQTT]
    enabled = 1

    – Go to Settings->Poller and configure the ThermIQ_MQTT, make sure you configure MQTTClient_Name with your ThermIQ name (ThermIQ_”YOURMACADR”) and MQTTNode etc according to your setup

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.