Uppdatera Thermiq på Raspberry

Shop Forum ThermIQ och Linux Uppdatera Thermiq på Raspberry

Visar 4 inlägg - 1 till 4 (av 4 totalt)
  • Författare
    Inlägg
  • #6324
    Mischel
    Deltagare

    Jag kör v.2.4 på min Rasp och tänkte uppdatera till senaste version som tydligen är 2.5 rev 477.

    Men i revisionstexten står det följande:

    Revision: 466
    Message:
    Fixed updating on Raspberry including some important fixes in setup_script
    * Raspberry installs should be redone to run correctly (diff with previous will work)

    Tolkade det som att jag skall köra installationsskriptet enligt guiden igen men får
    för denna rad “sudo ./setup_script 2>&1 | sudo tee /var/thermiq_install.log” nedan felemeddelande.

    Vad gör jag fel?

    Unknown OS, please check your raspberry
    Linux thermiq 3.6.11+ #474 PREEMPT Thu Jun 13 17:14:42 BST 2013 armv6l GNU/Linux

    #6326
    Mischel
    Deltagare

    Lägger till även kommandona som visar att hämtningen av uppdateringen innan ovan felmeddelande ser ut att ha fungerat som det ska.

    pi@thermiq /tmp $ sudo wget https://www.thermiq.net/ThermIQ_Client/pkg_raspberry/setup_script
    –2014-01-14 13:05:50– https://www.thermiq.net/ThermIQ_Client/pkg_raspberry/set up_script
    Slår upp https://www.thermiq.net (www.thermiq.net)… 195.74.38.94
    Ansluter till https://www.thermiq.net (www.thermiq.net)|195.74.38.94|:80… ansluten.
    HTTP-begäran skickad, väntar på svar… 200 OK
    Längd: 6734 (6,6K) [text/plain]
    Sparar till: “setup_script”

    100%[======================================>] 6 734 –.-K/s på 0s

    2014-01-14 13:05:50 (46,5 MB/s) – “setup_script” sparades [6734/6734]

    pi@thermiq /tmp $ sudo chmod a+x setup_script
    pi@thermiq /tmp $ sudo ./setup_script 2>&1 | sudo tee /var/thermiq_install.log
    Unknown OS, please check your raspberry
    Linux thermiq 3.6.11+ #474 PREEMPT Thu Jun 13 17:14:42 BST 2013 armv6l GNU/Linux
    pi@thermiq /tmp $

    #6327
    Anders a
    Keymaster

    Oj då, 2.5 är en hel vecka gammal så den måste jag prova i kväll.

    Första raderna i setup_script:et som kollar att det är rätt maskin som man installerar mot. Har tydligen ändrats något… Är du modig så tar du bara bort första raderna.

    Ifall att du bytt maskinnamn så får du också samma fel… skall vara raspberrypi för att scriptet ska funka.

    #6334
    Mischel
    Deltagare

    Kan bekräfta att problemet var att jag i Linux ändrat hostnamn till “thermiq”, install.skriptet fungerade när jag ändrade tillbaka till “raspberrypi”.

    Efter uppdateringen hände ytterligare 2 fel som kan vara bra att känna till:

    – Jag kunde inte logga in på Thermiq. Visade sig att att ini-filen var tom så ngt hade hänt vid uppdateringen. Tydligen ett känt fel som är korrigerat sedan rev.467.

    – När jag försökte återställa ini-filen så provade jag att radera den och köra hela installationsskriptet en gång till. Nu fick jag en massa felmeddelanden i loggen om att alla paket inte kunde installeras pga att plats saknades.
    Efter en massa testande så valde jag att tanka ner senaste Wheezy från Rasbberrypi-sajten. Upptäckte då att den var på 2,5 GB och jag körde på ett SD-kort som var 2 GB. Så problemet vid uppdatering är troligtvis även att de nya uppdateringarna alltså inte får plats. Bytte ut till ett 8 GB Sandisk Class 10-kort (90 kr) och gjorde en ny ren installation. Hittills fungerar allt kalas och jag har nu v2.5beta5.

    Nu måste jag bara få till att kopiera in all min gamla data från backupen av Thermiqs databas hpdb…

Visar 4 inlägg - 1 till 4 (av 4 totalt)
  • Du måste vara inloggad för att svara på detta ämne.